Управляем чем угодно откуда угодно

Проблемы и глюки

Общие вопросы

Проблемы и глюки

Сообщение Gol » 04 сен 2013, 01:22

1. На новом ядре не завелись модули DSP. В процессе решения.
2. Wi-Fi модуль периодически засыпает, разбудить можно только на стороне Виртурилки (любым обращением к интерфейсу wlan0), при обращении с наружи - не просыпается. Временное решение - периодически (раз в 10-15 минут) вызывать ifconfig wlan0 > /dev/null
3. Установка GPIO стандартным линуксовым способом (экспорт) в режим direction:output value:high не работает. Всё остальное работает, а установка в логическую единицу не пашет. Решается использованием драйвера /dev/v2r_pins или /dev/v2r_gpio.
Аватара пользователя
Gol
 
Сообщения: 507
Зарегистрирован: 17 фев 2012, 01:44
Откуда: Тула-Свободный-Щёкино-Тула-Москва

Re: Проблемы и глюки

Сообщение andrewion » 04 сен 2013, 10:50

Обнаружил баг в драйвере v2r_pins при работе с пинами.

На GPIO87 (он же CON19) подключил светодиод и хочу его включить (т.е. подать на пин питание), делаю это через CON:
Код: Выделить всё
echo "set con19 output:1" > /dev/v2r_pins


Через CON не работает, питание не подается. А если сделать через драйвер v2r_gpio:
Код: Выделить всё
echo "set gpio87 output:1" > /dev/v2r_gpio


То на пин подаётся питание и всё работает как надо, т.е. подключённый светодиод работает. :D
Аватара пользователя
andrewion
 
Сообщения: 150
Зарегистрирован: 03 сен 2013, 21:46

Re: Проблемы и глюки

Сообщение Gol » 04 сен 2013, 13:54

andrewion писал(а):Обнаружил баг в драйвере v2r_pins при работе с пинами.

Ага, мой косяк. У первой версии железки часть пинов была по-другому расположена (т.е. для некоторых CON были другие значения GPIO), по-этому v2r_pins и тупит, по старым адресам пишет. Пофиксю.
Аватара пользователя
Gol
 
Сообщения: 507
Зарегистрирован: 17 фев 2012, 01:44
Откуда: Тула-Свободный-Щёкино-Тула-Москва

Re: Проблемы и глюки

Сообщение Vpro » 07 сен 2013, 00:08

Пытаюсь включить Виртурилку в режим клиента (не точки доступа). Правлю параметр "ap" в файле uEnv.txt. Задаю значение "off".
После перезагрузки, параметр снова прописывается в "on". Как победить?

И вопрос по файлу /etc/wpa_supplicant.conf : SSID и пароль для зашифрованной сети должен быть кодирован в шестнадцатиричную строку? или пишем как есть?
Аватара пользователя
Vpro
 
Сообщения: 16
Зарегистрирован: 07 сен 2013, 00:03

Re: Проблемы и глюки

Сообщение realizator » 07 сен 2013, 05:12

Vpro писал(а):Пытаюсь включить Виртурилку в режим клиента (не точки доступа). Правлю параметр "ap" в файле uEnv.txt. Задаю значение "off".
После перезагрузки, параметр снова прописывается в "on". Как победить?

И вопрос по файлу /etc/wpa_supplicant.conf : SSID и пароль для зашифрованной сети должен быть кодирован в шестнадцатиричную строку? или пишем как есть?

Насчет ap - ощущение что не сохраняется у вас отредактированный файл. Если правите на компьютере (через адаптер MicroSD-SD) то после сохранения извлеките карточку корректно (отмонтируйте в линуксе/на маке или через "Извлечение устройств" в винде). Если правили из консоли виртурилки - отмонтируйте раздел корректно.

Пароль пишем как есть.
Аватара пользователя
realizator
virt2real team
 
Сообщения: 641
Зарегистрирован: 17 фев 2012, 23:18

Re: Проблемы и глюки

Сообщение Vpro » 07 сен 2013, 13:30

realizator писал(а):Насчет ap - ощущение что не сохраняется у вас отредактированный файл.


Не сохраняется, в обоих случаях. Делаем строго по инструкции.

в консоли вводим:
mount /dev/mmcblk0p1 /mnt

После чего с помощью файл-менеджера админки (http://ip_addres/?filemanager) надо перейти в каталог /mnt, выбрать файл uEnv.txt (кликнуть по нему), отредактировать и сохранить (кнопка "Сохранить" под окошком редактирования).

После этого в консоли отмонтировать загрузочный раздел
umount /mnt

Монтируем снова - и снова ap=on
Последний раз редактировалось Vpro 07 сен 2013, 14:03, всего редактировалось 1 раз.
Аватара пользователя
Vpro
 
Сообщения: 16
Зарегистрирован: 07 сен 2013, 00:03

Re: Проблемы и глюки

Сообщение realizator » 07 сен 2013, 14:03

Vpro писал(а):
realizator писал(а):Насчет ap - ощущение что не сохраняется у вас отредактированный файл.


Не сохраняется, в обоих случаях. Делаем строго по инструкции.

в консоли вводим:
mount /dev/mmcblk0p1 /mnt

После чего с помощью файл-менеджера админки (http://ip_addres/?filemanager) надо перейти в каталог /mnt, выбрать файл uEnv.txt (кликнуть по нему), отредактировать и сохранить (кнопка "Сохранить" под окошком редактирования).

После этого в консоли отмонтировать загрузочный раздел
umount /mnt


Попробуйте методом исключения: измените настройки с настольного компьютера, подключив карточку через кардридер. Если все сохранится - значит в админке косячок какой-то с сохранением.
Аватара пользователя
realizator
virt2real team
 
Сообщения: 641
Зарегистрирован: 17 фев 2012, 23:18

Re: Проблемы и глюки

Сообщение Smit » 07 сен 2013, 18:38

Не пойму то ли глюк то ли мой косяк. Собрал прошивку из исходников. Включаю - все нормально,а вафли нет. Подцепил uart. Смотрю лог загрузки - модуль вафли не определяется. Пытаюсь через консольку залогинится и виртурилка ребутается. О_О
Smit
 
Сообщения: 126
Зарегистрирован: 07 сен 2013, 00:53

Re: Проблемы и глюки

Сообщение realizator » 08 сен 2013, 13:05

Smit писал(а):Не пойму то ли глюк то ли мой косяк. Собрал прошивку из исходников. Включаю - все нормально,а вафли нет. Подцепил uart. Смотрю лог загрузки - модуль вафли не определяется. Пытаюсь через консольку залогинится и виртурилка ребутается. О_О

А на старой прошивке при этом вайфай нормально работает?
Аватара пользователя
realizator
virt2real team
 
Сообщения: 641
Зарегистрирован: 17 фев 2012, 23:18

Re: Проблемы и глюки

Сообщение Smit » 08 сен 2013, 13:48

realizator писал(а):А на старой прошивке при этом вайфай нормально работает?

Да на оригинальной прошивке скачанной по ссылке с вики все работает.
Smit
 
Сообщения: 126
Зарегистрирован: 07 сен 2013, 00:53

След.

Вернуться в Общий раздел ("не знаю куда написать")

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3