Управляем чем угодно откуда угодно

Проблемы и глюки

Общие вопросы

Re: Проблемы и глюки

Сообщение РД00 » 01 апр 2015, 22:08

Пытаюсь получить настроечную таблицу :

Код: Выделить всё
gst-launch videotestsrc pattern=smpte ! TIDmaiVideoSink videoStd=D1_PAL videoOutput=composite accelFrameCopy=true numBufs=4 sync=false videoStd=D1_PAL autoselect=true


При запуске короткая вспышка - и черный экран.
РД00
 
Сообщения: 20
Зарегистрирован: 16 май 2014, 10:42

Re: Проблемы и глюки

Сообщение Noor » 05 апр 2015, 18:26

Когда включаешь лан0 то виртурилка вообще не грузится.Заходишь на флешку и в текстовом файле отключаешь и все работает
Мастер сам устанавливает закон
Noor
 
Сообщения: 342
Зарегистрирован: 04 сен 2013, 20:03

Re: Проблемы и глюки

Сообщение РД00 » 05 апр 2015, 23:58

А про мой видеовыход никто ничего не скажет ?

Залил заново последнюю прошивку virt2real-1.07.002.img.
Поставил ядро uImage.master Digital camera SD mode (640x480 max)
Поставил настройки видео :

Видеовыход Композит
Видеорежим PAL
OSD davincifb:vid0=720x576x16,2500K:vid1=720x576x16,2500K:osd1=0x0x8:osd0=720x480x16,1350K@0,0
Интерфейс захвата 1
Режим IPIPE 0
Буфер cont2_bufsize 6291456
bufoffset 6291456
Буфер cont_bufsize 12067520

Загружаюсь, получаю синхронизированную картинку с зеленой полосой внизу экрана. Проверяю в админке, что камера работает.

Запускаю пример из Wiki "Вывод на НЧ":

Код: Выделить всё
gst-launch v4l2src always-copy=false chain-ipipe=true ! video/x-raw-yuv,format=\(fourcc\)NV12,width=640,height=480 ! dmaiaccel ! TIDmaiVideoSink videoStd=D1_PAL videoOutput=composite accelFrameCopy=true numBufs=4 sync=false videoStd=D1_PAL autoselect=true


Получаю несинхронизированную картинку с мелькающими горизонтальными полосами :

Изображение

В каком направлении копать ?
РД00
 
Сообщения: 20
Зарегистрирован: 16 май 2014, 10:42

Re: Проблемы и глюки

Сообщение phoenix367 » 06 апр 2015, 01:02

РД00 писал(а):А про мой видеовыход никто ничего не скажет ?

Залил заново последнюю прошивку virt2real-1.07.002.img.
Поставил ядро uImage.master Digital camera SD mode (640x480 max)
Поставил настройки видео :

Видеовыход Композит
Видеорежим PAL
OSD davincifb:vid0=720x576x16,2500K:vid1=720x576x16,2500K:osd1=0x0x8:osd0=720x480x16,1350K@0,0
Интерфейс захвата 1
Режим IPIPE 0
Буфер cont2_bufsize 6291456
bufoffset 6291456
Буфер cont_bufsize 12067520

Загружаюсь, получаю синхронизированную картинку с зеленой полосой внизу экрана. Проверяю в админке, что камера работает.

Запускаю пример из Wiki "Вывод на НЧ":

Код: Выделить всё
gst-launch v4l2src always-copy=false chain-ipipe=true ! video/x-raw-yuv,format=\(fourcc\)NV12,width=640,height=480 ! dmaiaccel ! TIDmaiVideoSink videoStd=D1_PAL videoOutput=composite accelFrameCopy=true numBufs=4 sync=false videoStd=D1_PAL autoselect=true


Получаю несинхронизированную картинку с мелькающими горизонтальными полосами :

В каком направлении копать ?


содержимое uEnv.txt сюда выложите. Может удастся понять, почему так. Просто у меня видеовыход работает нормально, но со старой прошивкой.
phoenix367
 
Сообщения: 193
Зарегистрирован: 09 сен 2013, 00:19

Re: Проблемы и глюки

Сообщение РД00 » 06 апр 2015, 01:54

phoenix367,
спасибо, отбой вопросу, победа, разобрался :) Сделал все по Вашему посту http://forum.virt2real.ru/viewtopic.php?f=44&t=13407#p18067 и получил видео.

В uEnv.txt выставить
Код: Выделить всё
video=davincifb:osd1=0x0x8:osd0=0x0x16,1350K@0,0


Видео с камеры на видеовыход:
Код: Выделить всё
gst-launch v4l2src always-copy=false chain-ipipe=true ! \
video/x-raw-yuv,format='(fourcc)'NV12,width=640,height=480 ! dmaiaccel ! \
 TIDmaiVideoSink videoStd=D1_PAL videoOutput=composite accelFrameCopy=FALSE sync=false


Настроечная таблица:
Код: Выделить всё
gst-launch -v videotestsrc ! video/x-raw-yuv,format='(fourcc)'NV12,width=720,height=576 ! \
TIDmaiVideoSink videoStd=D1_PAL videoOutput=composite accelFrameCopy=FALSE sync=false
РД00
 
Сообщения: 20
Зарегистрирован: 16 май 2014, 10:42

Re: Проблемы и глюки

Сообщение Noor » 08 май 2015, 20:30

ivideon не работает. Там все обновилось и теперь не хочет показывать камеру, хотя и видит ее.
Мастер сам устанавливает закон
Noor
 
Сообщения: 342
Зарегистрирован: 04 сен 2013, 20:03

Re: Проблемы и глюки

Сообщение myurav » 22 июл 2015, 22:43

Добрый день

Прикупили Вирт2реал с аналоговым видеовходом.

При правке в uEnv.txt, с
Код: Выделить всё
video=davincifb:osd1=0x0x8:osd0=720x480x16,1350K@0,0
на
Код: Выделить всё
 video=davincifb:osd1=0x0x8:osd0=0x0x16,1350K@0,0
нижняя часть экрана (светлая) растягивается на весь экран.
При трансляции с камеры на видео выход на экране можно понять что что то меняется. (при повороте камеры и пр.), но все равно мусор.
пробовали на разных мониторах.
При загрузке и при всех остальным манипуляциях на экране подключенному к ноге композитного видеовыхода (CON45 TVOUT CON66 A_GND ) вот такая картинка.
Землю на другую ножку тоже переставлял (CON69 DSP_GND )
Вложения
IMG_20150722_202647_125.jpg
До
IMG_Posle2.jpg
После
myurav
 
Сообщения: 12
Зарегистрирован: 22 июл 2015, 21:20

Re: Проблемы и глюки

Сообщение myurav » 22 июл 2015, 23:02

Да, на всякий случай
прошивка - virt2real-1.07.002
ядро - uImage.tvp5150
Видео
Видеовыход Композит
Видеорежим PAL
myurav
 
Сообщения: 12
Зарегистрирован: 22 июл 2015, 21:20

Re: Проблемы и глюки

Сообщение Serg » 23 июл 2015, 00:24

так а чем транслируете на экран то? Там же какая-то цепочка gstreamer должна быть. Возможно косяк в ней?
Serg
 
Сообщения: 121
Зарегистрирован: 07 сен 2013, 23:55

Re: Проблемы и глюки

Сообщение myurav » 23 июл 2015, 01:37

Стандартной цепочкой с форума. Пишу с телефона, не удобно копировать.
Вопрос, где видео при загрузке? Нас трое ч ная таблица тоже в таком же виде (цвета просматриваются)
myurav
 
Сообщения: 12
Зарегистрирован: 22 июл 2015, 21:20

Пред.След.

Вернуться в Общий раздел ("не знаю куда написать")

Кто сейчас на конференции

Сейчас этот форум просматривают: Bing [Bot] и гости: 2

cron