Управляем чем угодно откуда угодно

[РЕШЕНО] Зависает при использовании моторшилда

Виртурилка, 3G/4G, WiFi, моторчики, датчики, GPS и прочее - питание, драйвера, совместимость и т.д.

[РЕШЕНО] Зависает при использовании моторшилда

Сообщение bigbn » 17 июн 2016, 21:22

Подключаю питание к шилду, включаю виртурилку, захожу в админку, на макете подаю сигнал на один из пинов - подключенный двигатель начинает вращатся без остановки, виртурилка не отвечает, веб-морда становится недоступной. Пробовал менять питание как к виртурилке так и к шилду, история одна и та-же. Пробовал переключать джамперы, вобще как будто никаких изменений.
На виртурилку идут 2 литий-ионные по 3.7 вольта, на шилд 6 AAA аккумуляторов по полтора вольта. Что такое может быть, как и куда копать, не могу найти решения (
Самая последняя прошивка. USB-wifi. Камера не подключена.
Вложения
2016.jpg
Текущее положение джамперов
Последний раз редактировалось bigbn 26 май 2017, 21:55, всего редактировалось 1 раз.
bigbn
 
Сообщения: 24
Зарегистрирован: 05 окт 2013, 21:33

Re: Зависает при использовании моторшилда

Сообщение bigbn » 18 июн 2016, 21:44

Это все-таки похоже на проблему с питанием, но мне непонятно почему. Когда не подаешь полную мощь на двигатели то какое-то время они работают, отзываются нормально, а потом зависают и крутятся бесконечно, зависает виртурилка. Большая нагрузка на виртурилку? Падает напряжение в цепи? Тогда расскажите от чего питаете вы и почему у вас таких проблем не возникало?
bigbn
 
Сообщения: 24
Зарегистрирован: 05 окт 2013, 21:33

Re: Зависает при использовании моторшилда

Сообщение bigbn » 19 июн 2016, 17:17

Запитал от двух двеннадцати-вольтовых блоков питания, то же самое. Ну не может же быть, что дело в питании, и не в моторшилде(потому что у меня их 2, и не в виртурилке, потому что у меня их тоже две и все они ведут себя одинаково). Незнаю куда копать, в печали, а тут еще и форум мертв (
bigbn
 
Сообщения: 24
Зарегистрирован: 05 окт 2013, 21:33

Re: Зависает при использовании моторшилда

Сообщение realizator » 20 июн 2016, 14:42

bigbn писал(а):Запитал от двух двеннадцати-вольтовых блоков питания, то же самое. Ну не может же быть, что дело в питании, и не в моторшилде(потому что у меня их 2, и не в виртурилке, потому что у меня их тоже две и все они ведут себя одинаково). Незнаю куда копать, в печали, а тут еще и форум мертв (

1. Какая прошивка? Лучше точное название файла, который заливали. Бывает что скачивают последнюю прошивку на первой странице темы про прошивки (viewtopic.php?f=43&t=13296) версию 18_06_2014, а на самом деле там есть вторая страница с остальными сообщениями и последней прошивкой (1.09.003).
2. "Зависание" выражается в том что не отвечает админка? Как себя в этом состоянии ведут светодиоды на виртурилке?
3. Вы пробовали подключаться в консоль и смотреть как себя чувствует виртурилка, когда она "зависает"?
Аватара пользователя
realizator
virt2real team
 
Сообщения: 641
Зарегистрирован: 17 фев 2012, 23:18

Re: Зависает при использовании моторшилда

Сообщение bigbn » 20 июн 2016, 19:27

1. Прошивка virt2real-1.09.003.img (uImage.hd Digital camera HD mode (1280x720 max))
Код: Выделить всё
[root@virt2real ~]# uname -a
Linux virt2real 3.9.0-rc6-virt2real+ #2 PREEMPT Tue Nov 24 17:07:12 MSK 2015 armv5tejl GNU/Linux


2. Зависание проявляется в том что, виснет подключение по ssh, пропадает WI-FI, заклинивает вращение двигателей(они продолжают крутиться но делают это бесконечно), светодиоды никак не изменяются, все так же горят и синий и красный и изредка "чирикает" зеленый(что как-будто намекает, что процессор не завис).

3. Когда подключен по ssh - то тупо выкидывает. Попробую я ка я сейчас по USB сети подергать колесами, у меня появилось осознание того, что скорее всего это не виртурилка, а падает wifi. Ведь скрипты, что мои, что стандартные(макет или telegue) реагируют на нажатия клавиш, и когда сокет разорван то keyup до виртурилки просто не доходит, вот и выглядит будто она висит а моторчкики продолжают крутиться.

WI-FI ксати TP-link WN723N
bigbn
 
Сообщения: 24
Зарегистрирован: 05 окт 2013, 21:33

Re: Зависает при использовании моторшилда

Сообщение bigbn » 20 июн 2016, 19:32

Ну да, по USB-сети все работает четко, без зависаний. Пойду снова форум окучивать, я где-то там видел уже тему про этот свисток.
bigbn
 
Сообщения: 24
Зарегистрирован: 05 окт 2013, 21:33

Re: Зависает при использовании моторшилда

Сообщение bigbn » 20 июн 2016, 20:40

Короче у меня дома есть 3 свистка: TP-LINK WN723N, еще какой-то TP-LINK(корпус я к сожалению выкинул а на плате не написано, но не суть) и еще крохотный свисток EDUP. Все три отваливаются при использовании моторшилда, получается что питание все-таки настролько сильно проседает, что они просто отваливаются? Неужели нужно еще активный хаб туда подключать? Ведь вы же как то гоняете, и по выставкам еще успеваете ваши танчики показывать и прочие автономные девайсы, у вас ведь нет речи о хабах ))
bigbn
 
Сообщения: 24
Зарегистрирован: 05 окт 2013, 21:33

Re: Зависает при использовании моторшилда

Сообщение bigbn » 20 июн 2016, 21:45

Сменил ОТГ кабель, гоняю уже полчаса. Проклятые китайцы!!!
bigbn
 
Сообщения: 24
Зарегистрирован: 05 окт 2013, 21:33

Re: Зависает при использовании моторшилда

Сообщение realizator » 20 июн 2016, 21:48

bigbn писал(а):Короче у меня дома есть 3 свистка: TP-LINK WN723N, еще какой-то TP-LINK(корпус я к сожалению выкинул а на плате не написано, но не суть) и еще крохотный свисток EDUP. Все три отваливаются при использовании моторшилда, получается что питание все-таки настролько сильно проседает, что они просто отваливаются? Неужели нужно еще активный хаб туда подключать? Ведь вы же как то гоняете, и по выставкам еще успеваете ваши танчики показывать и прочие автономные девайсы, у вас ведь нет речи о хабах ))

У виртурилки встроенная схема питания рассчитана на нагрузку до 2 ампер. Моторшилд я так понял вы отдельно питаете. Не должно быть проседания.
А если моторшилд отключить - коннект по вайфаю стабильный?
И еще вопрос - а видео вы отправляете? Если да то какой битрейт?
Аватара пользователя
realizator
virt2real team
 
Сообщения: 641
Зарегистрирован: 17 фев 2012, 23:18

Re: Зависает при использовании моторшилда

Сообщение realizator » 20 июн 2016, 21:48

bigbn писал(а):Сменил ОТГ кабель, гоняю уже полчаса. Проклятые китайцы!!!

Поздравляю! :-)
Аватара пользователя
realizator
virt2real team
 
Сообщения: 641
Зарегистрирован: 17 фев 2012, 23:18

След.

Вернуться в Железо - заставляем работать

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 4

cron