Управляем чем угодно откуда угодно

Собрал, залил, включил... и нифига не понимаю.

Глупых вопросов не бывает! Раздел для тех, кто только начинает.

Re: Собрал, залил, включил... и нифига не понимаю.

Сообщение andrewion » 18 сен 2013, 11:17

Arle писал(а):Только В2Р у меня на usb висит , а везде надо по айпи коннектиться... или я не понимаю что то? wifi в компе нет.
с чего лучше начать развитие скилла и откуда взять хоть какую оболочку для управления в2р?


Да, везде надо по IP коннектиться. Попробуйте с любого устройства с WiFi, зайти по IP в админку виртурилки и там сделать возможность подключение к ней минуя WiFi - через USB. Как настроить виртурилку для работы по USB, читать тут http://forum.virt2real.ru/viewtopic.php?f=38&t=13267
Аватара пользователя
andrewion
 
Сообщения: 150
Зарегистрирован: 03 сен 2013, 21:46

Re: Собрал, залил, включил... и нифига не понимаю.

Сообщение Arle » 18 сен 2013, 12:20

Поднялась =) прикольно.
Аватара пользователя
Arle
 
Сообщения: 35
Зарегистрирован: 09 сен 2013, 16:42

Re: Собрал, залил, включил... и нифига не понимаю.

Сообщение Mirmik » 18 сен 2013, 13:32

вообще, имеет смысл сходить в магазин и за 500-600 рублей взять простенький роутер.
... и перерастворяясь из одной формы реальности в другую. И вот он я, рядом с вами падаю в эту же нору, тот кто волшебной палочкой вра...
Аватара пользователя
Mirmik
 
Сообщения: 221
Зарегистрирован: 04 сен 2013, 19:20
Откуда: Московская область, Пушкино

Re: Собрал, залил, включил... и нифига не понимаю.

Сообщение Arle » 19 сен 2013, 02:00

Я на работе собрал себе комп на линуксе для нашей затеи и воткнул туда вайфай pci модуль. Будет он у меня роутером )
Аватара пользователя
Arle
 
Сообщения: 35
Зарегистрирован: 09 сен 2013, 16:42

Re: Собрал, залил, включил... и нифига не понимаю.

Сообщение Arle » 20 сен 2013, 09:51

Подскажите как сервомашинку крутить на в2р.
купил машинки. а заставить крутиться не могу.
подключил к питанию черный и красный провода напрямую, а белый повесил на con44 на виртуриле. задал |echo "set con44 pwm1" > /dev/v2r_pins|
после чего пробую echo "set pwm1 duty:1000 period:1500" > /dev/v2r_pins
ну и ничего не происходит. что не правильно делаю? с сервы на плату падает только 1 контакт - белый.
Аватара пользователя
Arle
 
Сообщения: 35
Зарегистрирован: 09 сен 2013, 16:42

Re: Собрал, залил, включил... и нифига не понимаю.

Сообщение phoenix367 » 20 сен 2013, 09:56

Arle писал(а):Подскажите как сервомашинку крутить на в2р.
купил машинки. а заставить крутиться не могу.
подключил к питанию черный и красный провода напрямую, а белый повесил на con44 на виртуриле. задал |echo "set con44 pwm1" > /dev/v2r_pins|
после чего пробую echo "set pwm1 duty:1000 period:1500" > /dev/v2r_pins
ну и ничего не происходит. что не правильно делаю? с сервы на плату падает только 1 контакт - белый.


Так вроде сервопривод нужно через плату управления моторами подключать, а не на прямую. А ее пока не прислали и не известно когда рассылать начнут. На самой базовой плате драйвер моторов не распаян.
phoenix367
 
Сообщения: 193
Зарегистрирован: 09 сен 2013, 00:19

Re: Собрал, залил, включил... и нифига не понимаю.

Сообщение Mirmik » 20 сен 2013, 17:54

1000 очень мало... попробуйте duty 20000 period 70000. это, правда на память... но вроде у меня на этих числах
работало.
... и перерастворяясь из одной формы реальности в другую. И вот он я, рядом с вами падаю в эту же нору, тот кто волшебной палочкой вра...
Аватара пользователя
Mirmik
 
Сообщения: 221
Зарегистрирован: 04 сен 2013, 19:20
Откуда: Московская область, Пушкино

Re: Собрал, залил, включил... и нифига не понимаю.

Сообщение Mirmik » 20 сен 2013, 17:56

phoenix367 писал(а):
Arle писал(а):Подскажите как сервомашинку крутить на в2р.
купил машинки. а заставить крутиться не могу.
подключил к питанию черный и красный провода напрямую, а белый повесил на con44 на виртуриле. задал |echo "set con44 pwm1" > /dev/v2r_pins|
после чего пробую echo "set pwm1 duty:1000 period:1500" > /dev/v2r_pins
ну и ничего не происходит. что не правильно делаю? с сервы на плату падает только 1 контакт - белый.


Так вроде сервопривод нужно через плату управления моторами подключать, а не на прямую. А ее пока не прислали и не известно когда рассылать начнут. На самой базовой плате драйвер моторов не распаян.


сервопривод - изделие не капризное... ему нужно лишь питание и импульсы на сигнальном проводе...
... и перерастворяясь из одной формы реальности в другую. И вот он я, рядом с вами падаю в эту же нору, тот кто волшебной палочкой вра...
Аватара пользователя
Mirmik
 
Сообщения: 221
Зарегистрирован: 04 сен 2013, 19:20
Откуда: Московская область, Пушкино

Re: Собрал, залил, включил... и нифига не понимаю.

Сообщение Mirmik » 20 сен 2013, 19:11

Поправка. Период я за давал 700000.
0 градусов - duty 13000
180 градусов - duty 57000
... и перерастворяясь из одной формы реальности в другую. И вот он я, рядом с вами падаю в эту же нору, тот кто волшебной палочкой вра...
Аватара пользователя
Mirmik
 
Сообщения: 221
Зарегистрирован: 04 сен 2013, 19:20
Откуда: Московская область, Пушкино

Re: Собрал, залил, включил... и нифига не понимаю.

Сообщение N_D_Z » 28 сен 2013, 19:08

Пардон за "некро"-пост, но тоже столкнулся с проблемой неотзывчивой консоли в админке.
Если интересно откуда ноги растут, то у меня есть подозрения что возможно это как-то связано с тем, что флешку я шил через телефон на андроиде (пробовал кучу раз, форматировал, заливал с винды и убунты. Везде результат один - консоль перерисовывается после каждой команды, вместо ее выполнения).

Ssh помог - пожалуйста, добавьте в вике об этом параграф :)
N_D_Z
 
Сообщения: 1
Зарегистрирован: 28 сен 2013, 18:42

Пред.След.

Вернуться в Раздел "для чайников"

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2